Back to overview
Downtime
MyAnimeList is down
May 10, 2023 at 09:03pm UTC
Affected services
MyAnimeList
Resolved
May 13, 2023 at 03:13am UTC
MyAnimeList is back online, and imports are functioning once more!
Affected services
Created
May 10, 2023 at 09:03pm UTC
MyAnimeList has gone down for emergency maintenance. We are monitoring the situation and will update this page when we have more information. For more information, please see the MyAnimeList status page.
Affected services